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Introduction 
RMFT is a managed file transfer platform that facilitates secure file exchange between an organization's internal 
users, external users, and business partners. RMFT Outlook Add-in brings many of RMFT’s file sending and 
auditing capabilities to Microsoft Office Outlook, enabling Outlook users with RMFT accounts to send and track 
files and folders of virtually any size. 
 
When you send a message with attachments via RMFT, the files are uploaded to RMFT Server where they are 
replaced by links for downloading the files. RMFT Server sends the recipients an email message containing the file 
download links. You can track the upload of files to RMFT Server and request to be notified whenever the files are 
downloaded. 
 

In this guide: Chapter 1: Sending Files and Folders explains how to send files and folders with RMFT 
Outlook Add-in, how to set sending options for each message, how to track transfer 
progress, and how to recall files. 

Chapter 2: RMFT Outlook Add-in Options explains how to modify the default 
attachment, expiration, notification and categorization options. 

Chapter 3: Connection Settings explains how to configure connectivity to RMFT Server. 

Appendix A: Troubleshooting provides resolutions to problems that may occur while 
using RMFT Outlook Add-in. 

 
The instructions in this guide assume that you are using the RMFT toolbars which are displayed by default after 
RMFT Outlook Add-in is installed. The RMFT toolbars appear in the main Outlook window and in the Message 
window’s Message and Insert ribbons.  
 

Outlook Version RMFT Toolbar in the Main Outlook 
Window 

RMFT Toolbar in Outlook's Message and Insert 
Ribbons 

2010 

   

2007 
 

 

 

Note: If the toolbars are not shown, select Toolbars > RMFT from the View menu. The 
Connection, Options, Help and About buttons are also available through the Tools > RMFT 
menu.  
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1.  Sending Files and Folders 
with RMFT 

In this chapter, the following tasks are explained: 

 Sending files and folders with RMFT 

 Overriding the default RMFT sending options 

 Tracking transfer progress 

 Recalling files sent with RMFT 

 

Note: Files can be added using Outlook's Attach File option or the Add File option in the RMFT toolbar. Whereas 
files added using Outlook's Attach File option will only be sent with RMFT if the RMFT Outlook Add-in settings are 
configured accordingly, files added with the Add File option in the RMFT toolbar will always be sent with RMFT. 
For more information on configuring RMFT Outlook Add-in to send regular Outlook attachments (i.e. files attached 
with Outlook's Attach File option) with RMFT, see 2.  Options. 

To send files or folders with RMFT: 

1.     Click . 

The Message window opens. 

 

2.     In the To field, specify the email addresses of the designated recipients.  

Note: If you receive an error that a certain recipient does not exist (even though you specified a valid 
email address), please contact your RMFT administrator and request to be granted the appropriate 
sending privileges.  

3.     Optionally, in the Subject field, specify a subject. 

4.     To add files, click the Add File button in the RMFT toolbar (or click the Attach File button in Outlook's 
Include toolbar). 
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The Open dialog box opens. 

 

5.     Select the files that you want to send and then click Open. 

Metadata files containing information about the location of the actual files are attached to the message. 
The metadata files have the same name as the actual files but a different extension, which will either be 
rmftfhlink (if the files are in their original location) or rmftfslink (if the files have been copied to a 
temporary directory).  

 

6.     To add a folder, click the Add Folder button in the RMFT toolbar. 

The Open dialog box opens. 

7.     Select the folder that you want to send and then click Open. 

A metadata file containing information about the folder’s location is attached to the message. The 
metadata file has the same name as the folder and will either be appended with the extension 
rmftdslink (if the files are in their original location) or rmftdhlink (if the files have been copied to a 
temporary directory). 

 

8.     To zip all of the attachments into a single archive, click the Zip button in the RMFT toolbar (the option 
may already be enabled if the Zip option is enabled in the default settings – for more information, see 2.  
Options).  
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To set a password to protect the contents of the zip file, click the downward arrow below the Zip button 
and then select Set Password. 

Note: You do not need to enable the Zip option when sending a single folder as folders are always zipped 
before being sent. You may however want to enable the Zip option when sending multiple folders (or 
multiple attachments), as this will zip all attachments into a single archive.  

9.     To override the default sending options, click the Options button. For a description of the available 
options, see Message Options below.  

10.    Click Send. 

The message is first moved to your Outbox and then to your Sent Items folder. In the Sent Items folder, 
the metadata files are replaced with download links. 

 

For information about tracking the file transfer, see Tracking Transfer Progress. 

Message Options 

For each new message, you can override the default Expiration and Sending and Tracking options defined for the 
RMFT Outlook Add-in. 

To open the Message Options dialog box: 

1.     Click the  (Options) button in the RMFT toolbar. 

 

2.     For an explanation of the Expiration and Sending and Tracking options, see Expiration and Sending and 
Tracking respectively. 

3.     Click Save to save your settings for the current message. 



 1.  Sending Files and Folders with RMFT 
 

 

RepliWeb, Inc. 8 

 

Tracking Transfer Progress 

After you click Send, messages sent with RMFT will be moved to your Outbox folder where you can view the file 
transfer progress. Note that transfer time (i.e. the time that the message remains in your Outbox) will vary 
according to the total size of the files transferred and the network load at the time of transfer.  

 

Figure 1: Transfer Progress of Files sent with RMFT 

 
If, for whatever reason, RMFT Outlook Add-in is unable to send the files, it will continue trying until it either 
succeeds or exhausts all of its recovery attempts.   

 

Figure 2: Attempting to Send the Files after Initial Failure 

 
You can abort the sending at any time by simply right-clicking the message and selecting Delete. 
 
After the files are sent, the message containing links to download the files will be moved to your Sent Items 
folder. 

 

Figure 3: Message sent with RMFT 
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Recalling Files sent with RMFT 

You can recall files sent with RMFT using Outlook’s Message Recall option. This is a two-stage process involving 
first recalling the files and then recalling the message itself.  
 

Note: Files recalled from RMFT will be indicated by a  icon in 
the Sent Items folder. 
 

 

To recall files sent with RMFT: 

1.     Open the relevant message in your Sent Items folder. 

2.     Click Other Actions and then select Recall This Message from the drop-down menu.  

 

A prompt appears asking you to confirm your request to recall the files sent with RMFT. 
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Note: Recalling the files prevents future access to the files, but does not affect files which may have 
already been downloaded by the recipients. It also does not recall the Outlook message itself, which you 
will need to recall separately. 

3.     Click OK.  

Another prompt appears asking you to confirm your request to recall the Outlook message. 

 

4.     Click OK. If you choose not to recall the Outlook message (not recommended), recipients will receive the 
message, but will not be able to download the files. 
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2.  Options 
In the Options dialog box, you can perform the following tasks: 

 Specify criteria for sending Outlook attachments with RMFT  

 Specify whether files added with the RMFT toolbar should be copied to a temporary directory before 
sending 

 Enable zipping 

 Set an expiration period after which recipients will not be able to download files  

 Request notifications and configure message sending options 

 Categorize sent items as “Sent with RMFT” 

To open the RMFT Outlook Add-in Options dialog box: 
♦ Click the  (Options) button in the RMFT toolbar (in the main Outlook window). 

The RMFT Outlook Add-in Options dialog box opens. 
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Outlook Attachments  

Note: Outlook Attachments are files that have been attached to the message using Outlook's Attach File 
button.  

Option Description 

Send as regular Outlook attachments Send the attached files as regular Outlook 
attachments (i.e. not with RMFT). 

Send all files with RMFT Send all attachments with RMFT, regardless of size 
or type. 

Send all files with RMFT only if any of the 
following conditions are met: 

Specify criteria for sending Outlook attachments 
with RMFT. If the specified sending criteria is 
either fully or partially met, the message will be 
sent using RMFT. For example, if you specified to 
send messages with RMFT when the total 
attachment size exceeds 2 MB and the attached 
file types are Word documents (.doc), the 
messages will be sent with RMFT as long as the 
attachments exceed 2 MB, even if they are not 
Word documents.  

Note: Attachments that do not meet any of the 
criteria for sending with RMFT will be sent as 
regular Outlook attachments. 

Total file size exceeds Send all of the attachments with RMFT if their 
combined size is larger than the specified size. 

File types include (unsafe types will be 
ignored) 

Send all of the attachments with RMFT if at least 
one of the attached files matches the specified file 
type. File types must be separated by a semi-colon 
without spaces (but do not need to be prefixed 
with a period), for example: 
avi;mpeg 

Note: Unsafe file types (such as .exe or .bat files) 
attached using the standard Outlook "Attach File" 
option cannot be sent with RMFT. To send unsafe 
file types with RMFT, add them to the message 
using the "Add File" option in the RMFT toolbar.   

Always ask before sending with RMFT Always ask whether files attached using Outlook’s 
Attach File option and that meet the specified 
sending criteria should be sent with RMFT. 
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RMFT Attachments  

Note:  RMFT Attachments are files that have been added to the message using the Add File or 
Add Folder buttons in the RMFT toolbar. 

Option Description 

Send files/folders from their original 
locations. 

Send files from their original locations. 

If some files/folders are missing: 

Send anyway Send the files even if some of them are missing. 
Files may be missing, for example, if they were 
deleted from the disk after being added to the 
message.   

Do not send Do not send any of the files if some of the files 
are missing.   

Copy files/folders to a temporary folder Select this option to prevent files from being 
modified (i.e. by other applications) before they 
are sent. 

Choose Just files to only copy files to a 
temporary location or Files and folders to copy 
both files and folders to a temporary location 
before sending. 

 

ZIP 

Option Description 

Zip all attachments into one archive 
before sending with RMFT. 

Zip all files/folders and send them as a single 
archive. 

Note: Zipping large files or certain file types may 
increase transfer speed while zipping file 
formats that already compressed (such as jpegs 
and mpegs) will have little effect on file size and 
may even reduce the transfer speed and place 
an unnecessary burden on the CPU. 

 

Expiration 

Option Description 

Allow recipients to download files for Only allow recipients to download the attached 
files for the specified number of days. 
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Note: A shorter expiration period defined by 
your RMFT administrator (on RMFT Server) will 
override any expiration period that you specify 
here. For example, if you specify 20 days and the 
expiration period defined on RMFT Server is 10 
days, the expiration period will be 10 days. 

 

Sending and Tracking 

Option Description 

Notify me about downloads Receive notifications whenever the files are 
downloaded by the recipients. 

If you send the message to multiple recipients, 
The notifications will not inform you which 
recipients downloaded the files unless you also 
select the Mail each recipient separately option 
(below). 

Mail each recipient separately Send a separate message to each recipient. If 
you select this option together with the Notify 
me about downloads option, you will be 
notified whenever the files are downloaded as 
well as which recipients downloaded them. 

Note: When this option is selected, two 
messages will be sent. The first will be sent to all 
of the specified recipients, allowing them to 
reply to any/all of the other recipients. The 
second will be sent to each recipient individually 
and allow them to download the files. 

Require login to download files Recipients will be required to log in to download 
the files (using their RMFT username and 
password). 

Note: When this option is selected and the email 
is sent to multiple recipients, two messages will 
be sent. The first will be sent to all of the 
specified recipients, allowing them to reply to 
any/all of the other recipients. The second will 
be sent to each recipient individually and allow 
them to access the files. 
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Category 

Option Description 

Categorize items sent using RMFT as 
“Sent with RMFT”. 

Categorize items sent using RMFT as “Sent with 
RMFT”. If you select this option, messages sent 

using will be indicated with a  icon (in all 
Outlook folders). 
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3.  Connection Settings 
Your connection settings determine how RMFT Outlook Add-in connects to RMFT Server in order to upload files. 
These settings should not be modified unless instructed by your RMFT Administrator. 

To open the RMFT Outlook Add-in – Connection Settings dialog box: 
 

♦ Click the  button in the RMFT toolbar. 

The RMFT Outlook Add-in – Connection Settings dialog box opens. 

 

 

Option Description 

RMFT Server   Select either Server Details or Server URL according to the 
instructions that you received from your RMFT administrator. 

Server Details   If you select this option, in the Server Name field, specify the IP 
address or hostname of the RMFT Server machine (as provided by 
your RMFT administrator). 

Server URL   If you select this option, specify the RMFT Server URL (as provided 
by your RMFT administrator). 

 

 

Example:  
http://org.domain.com:3102/RmftWebService 

Port The port through which RMFT Outlook Add-in communicates with 
RMFT Server. Do not change unless instructed to do so by your 
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RMFT administrator. 

Connection The method RMFT Desktop Client uses to connect to RMFT Server. 
Only choose methods which have been approved by your RMFT 
administrator. If you are not sure which method to choose, contact 
your RMFT administrator. 

Proxy   Choose one of the following options as appropriate: 

 None If you select this option, RMFT Outlook Add-in will connect 
directly to RMFT Server.  

 Auto-Detect If you select this option, RMFT Outlook Add-in will 
connect to RMFT Server as specified in your Windows settings 
(either directly or using a proxy server). 

 Manual Select this option to connect to RMFT Server via your 
organization's proxy server and then specify the IP address or 
hostname of your proxy server. 

o Proxy Server Specify the IP address or hostname of 
your proxy server. 

Port   The port through which RMFT Outlook Add-in communicates with 
your proxy server. Do not change unless you are sure that you 
proxy port is different. 

Use my Windows 
credentials   

Select this option if you normally log in to RMFT Server using your 
Windows credentials. Note that this method uses Integrated 
Windows Authentication (also known as NTLM) to authenticate 
your identity to RMFT Server. 

Use my RMFT credentials   Select this option if you normally log in to RMFT Server using your 
RMFT credentials or if you normally log in to RMFT Server using 
your Windows credentials but are currently logged in to your 
computer as a different user. 

Note: If you are not sure which credentials to use, please contact 
your RMFT Administrator. 

 Username Your RMFT username. 

 Password Your RMFT password. 

 Domain Only applicable if you are an Active Directory RMFT 
user and did not select Use my Windows credentials. Specify 
your Active Directory domain name. 

Test Connection   Click to test the connection to RMFT Server. 

Save Click to save your settings. 
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A. Troubleshooting 
This appendix highlights various issues that you may encounter when using RMFT Outlook Add-in. 
 

Problem Cause/Resolution 

Some of the RMFT Outlook Add-in settings are grayed out 
and cannot be changed. 

Options that are grayed out have been pre-
configured by your RMFT administrator. Such 
options cannot be modified.  

I set the expiration option to Allow recipients to download 
files for <50> days, but one of the recipients contacted me 
after 20 days and said that the files had already expired. 

The maximum expiration period is set by the 
RMFT administrator. The administrator-defined 
expiration period overrides the user-defined 
package expiration periods. For example, an 
administrator-defined policy of 30 days will 
override a user-specified expiration period of 60 
days.  

The folowing message is displayed when I try to send files 
added with the RMFT toolbar: 

 
 and the message stays in my Outbox with the following text 
appended to the subject: 
- Error: missing attachments 

This message is displayed when the following 
option is selected in the Options dialog box: 

If some files/folders are missing or inaccessible: 
Don’t Send 

RMFT Outlook Add-in is configured to send files attached 
using the regular Outlook "Attach File" option with RMFT, 
and to zip the files before sending. When the Zip file 
contains file types that Outlook considers unsafe (e.g. exe), 
the message is sent, but the Zip file arrives without the 
unsafe file types.  

Unsafe file types attached using the Outlook 
"Attach File" option cannot be sent with RMFT. If 
you need to send unsafe file types, the solution is 
to add them with the RMFT "Add File" option. 

Sending email by right-clicking a file in Windows Explorer 
and selecting Send To > Mail Recipient does not send the 
message with RMFT even if RMFT Outlook Add-in is 
configured to send the file with RMFT. 

This functionality is currently not supported. The 
solution is to attach the files from Outlook's New 
Message window. 

A Copy Progress bar similar to the one shown below is 
displayed when I attach files using either the RMFT Add File 
or Add Folder option. 

This happens when the Copy files/folders to a 
temporary folder option is selected in the 
Options dialog box. 
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If you are attaching a folder with many files or if 
you are attaching a very large file, the copying 
process may take a few moments to complete. 

When using Internet Explorer to access your Gmail account, 
clicking the file download link (in the notification) does not 
open a download prompt. Instead, the Internet Explorer 
Information bar is displayed with an option to download the 
file. Subsequently selecting the download option in the 
Information bar loads a blank page with the Gmail copyright 
notice. 

By default, the Automatic prompting for file 
downloads option is disabled in Internet Explorer. 
Enabling this option will resolve the problem. If 
you only want to enable this option for the 
Trusted Sites Zone, add Gmail to the Trusted Sites 
Zone in the Options > Security tab. 

 

To enable the Automatic prompting for file 
downloads option, click the Custom level button 
in the Options > Security tab and then select the 
relevant item. 

 

 

When I mail a file from Windows Explorer or directly from 
Microsoft Office, the conditions for sending with RMFT are 
ignored. 

Mailing files from Windows Explorer or directly 
from Microsoft Office programs is currently not 
supported. 

RMFT zipped my attachments, even though I did not enable 
the "Zip all attachments…" option. 

RMFT does not support filenames with non-ascii 
characters. When you attach files with filenames 
that contain non-ascii characters, the only way 
that RMFT can process them is by automatically 
zipping them into a single zip file. 

I installed the RMFT Outlook Add-in, but none of the 
features are visible.  

Verify that RepliWeb RMFT Add-in is listed and 
enabled in the COM Add-Ins window. 

To open the COM Add-Ins window: 

1.     From the Tools menu, select Trust 
Center.  

2.     In the Trust Center window, select Add-
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ins in the left pane. 

3.     At the bottom of the Add-ins tab, make 
sure that COM Add-ins appears in the 
Manage drop-down list and then click 
Go. 

 

The COM Add-Ins window opens. 
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